彷徨うおのこ

死ぬまで死なないぜ おれは

pycharmをcentosで起動したいなぁ

前提:

これまでlinux上でのソースコード改修作業はviでやってたけど、流石に無理ゲーとなってきたのでpycharmをmac->linuxにインストールしたけど、下記のエラーがでるので困る。

エラー:

[root@z1tg7160-vm01 ~]# cd /opt/pycharm/bin/
[root@z1tg7160-vm01 bin]# ./pycharm.sh 


Startup Error: Unable to detect graphics environment

解決:

1.rootユーザ実行はよくないのでは?

https://stackoverflow.com/questions/46124295/pycharm-startup-error-unable-to-detect-graphics-environment

I had the same error installing in a clean Ubuntu 17.10, with Gnome on Wayland. At @mattdm's suggestion in your comments, I just opened a new terminal (as myself, not root) and it ran fine. I was running as root (after unpacking everything to /opt/) when I got the error.

rootでない、通常ユーザならばOK?
[centos@z1tg7160-vm01 ~]$ cd /opt/pycharm/bin/
[centos@z1tg7160-vm01 bin]$ ./pycharm.sh 


Startup Error: Unable to detect graphics environment
だめ!!!

2.pycharm問題ではなくXuser設定問題じゃね?

Your X environment is not properly set (manually setting DISPLAY doesn't always work). Possibly because you're attempting this as root and root is not the owner of the graphics session. There could be other reasons, too.
You won't be able to run xclock or any other X app either in this situation - this is the clue that it's not a pycharm-related problem. For example if you ssh to localhost as root, not as the user currently logged in into the graphical session:
To address this issue open a new terminal from the graphics environment - if it is properly installed you should be able to run any of the X apps, including pycharm (or at least it shouldn't fail with that error).
つまり、X app とやらをインストールして適用する。。。

サーバ
[root@z1tg7160-vm01 ~]# vi /etc/ssh/sshd_config 
[root@z1tg7160-vm01 ~]# service sshd reload
Redirecting to /bin/systemctl reload  sshd.service
クライアント
ssh接続
H1408326:~ user$ ssh -X -i xxx.pem centos@ipaddress
X11 forwarding request failed on channel 0
ああ失敗
クライアントのxclockの起動は確認できるけど

2.2X11Forwarding だけできない謎状態。それはxauthないから?

xauthを投入してみた。
[root@z1tg7160-vm01 bin]# yum install xauth
Loaded plugins: fastestmirror
base                                                     | 3.6 kB     00:00     
epel/x86_64/metalink                                     | 5.7 kB     00:00     
extras                                                   | 3.4 kB     00:00     
percona-release-noarch                                   | 2.9 kB     00:00     
percona-release-x86_64                                   | 2.9 kB     00:00     
updates                                                  | 3.4 kB     00:00     
updates/7/x86_64/primary_db                                | 5.0 MB   00:00     
Loading mirror speeds from cached hostfile
 * base: ftp-srv2.kddilabs.jp
 * epel: ftp.tsukuba.wide.ad.jp
 * extras: ftp-srv2.kddilabs.jp
 * updates: ftp-srv2.kddilabs.jp
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-xauth.x86_64 1:1.0.9-1.el7 will be installed
--> Processing Dependency: libXmuu.so.1()(64bit) for package: 1:xorg-x11-xauth-1.0.9-1.el7.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: 1:xorg-x11-xauth-1.0.9-1.el7.x86_64
--> Running transaction check
---> Package libXext.x86_64 0:1.3.3-3.el7 will be installed
---> Package libXmu.x86_64 0:1.1.2-2.el7 will be installed
--> Processing Dependency: libXt.so.6()(64bit) for package: libXmu-1.1.2-2.el7.x86_64
--> Running transaction check
---> Package libXt.x86_64 0:1.1.5-3.el7 will be installed
--> Processing Dependency: libSM.so.6()(64bit) for package: libXt-1.1.5-3.el7.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: libXt-1.1.5-3.el7.x86_64
--> Running transaction check
---> Package libICE.x86_64 0:1.0.9-9.el7 will be installed
---> Package libSM.x86_64 0:1.2.2-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch           Version               Repository    Size
================================================================================
Installing:
 xorg-x11-xauth         x86_64         1:1.0.9-1.el7         base          30 k
Installing for dependencies:
 libICE                 x86_64         1.0.9-9.el7           base          66 k
 libSM                  x86_64         1.2.2-2.el7           base          39 k
 libXext                x86_64         1.3.3-3.el7           base          39 k
 libXmu                 x86_64         1.1.2-2.el7           base          71 k
 libXt                  x86_64         1.1.5-3.el7           base         173 k

Transaction Summary
================================================================================
Install  1 Package (+5 Dependent packages)

Total download size: 418 k
Installed size: 950 k
Is this ok [y/d/N]: y
Downloading packages:
(1/6): libSM-1.2.2-2.el7.x86_64.rpm                        |  39 kB   00:00     
(2/6): libICE-1.0.9-9.el7.x86_64.rpm                       |  66 kB   00:00     
(3/6): libXext-1.3.3-3.el7.x86_64.rpm                      |  39 kB   00:00     
(4/6): libXmu-1.1.2-2.el7.x86_64.rpm                       |  71 kB   00:00     
(5/6): xorg-x11-xauth-1.0.9-1.el7.x86_64.rpm               |  30 kB   00:00     
(6/6): libXt-1.1.5-3.el7.x86_64.rpm                        | 173 kB   00:00     
--------------------------------------------------------------------------------
Total                                              1.8 MB/s | 418 kB  00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libICE-1.0.9-9.el7.x86_64                                    1/6 
  Installing : libXext-1.3.3-3.el7.x86_64                                   2/6 
  Installing : libSM-1.2.2-2.el7.x86_64                                     3/6 
  Installing : libXt-1.1.5-3.el7.x86_64                                     4/6 
  Installing : libXmu-1.1.2-2.el7.x86_64                                    5/6 
  Installing : 1:xorg-x11-xauth-1.0.9-1.el7.x86_64                          6/6 
  Verifying  : libXext-1.3.3-3.el7.x86_64                                   1/6 
  Verifying  : libICE-1.0.9-9.el7.x86_64                                    2/6 
  Verifying  : libSM-1.2.2-2.el7.x86_64                                     3/6 
  Verifying  : libXmu-1.1.2-2.el7.x86_64                                    4/6 
  Verifying  : libXt-1.1.5-3.el7.x86_64                                     5/6 
  Verifying  : 1:xorg-x11-xauth-1.0.9-1.el7.x86_64                          6/6 

Installed:
  xorg-x11-xauth.x86_64 1:1.0.9-1.el7                                           

Dependency Installed:
  libICE.x86_64 0:1.0.9-9.el7             libSM.x86_64 0:1.2.2-2.el7            
  libXext.x86_64 0:1.3.3-3.el7            libXmu.x86_64 0:1.1.2-2.el7           
  libXt.x86_64 0:1.1.5-3.el7             

Complete!

結果->だめ!

2.3/etc/ssh/sshd_configに一文たす

>>X11UseLocalhost no
結果:だめ。どうすんの??

3.pycharm.shの権限付与

>>sudo chmod +x pycharm.sh
結果:だめ
[centos@z1tg7160-vm01 bin]$ sudo chmod +x pycharm.sh
[centos@z1tg7160-vm01 bin]$ ./pycharm.sh 
Startup Error: Unable to detect graphics environment
うっぜ!!

4.jdkないよ

Do you use headless Java installation? Is it OpenJDK or Oracle JDK
Such errors may be caused by:
- your JDK is headless - doesn't include graphics libraries 
[root@z1tg7160-vm01 bin]# yum install openjdk
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp-srv2.kddilabs.jp
 * epel: ftp.tsukuba.wide.ad.jp
 * extras: ftp-srv2.kddilabs.jp
 * updates: ftp-srv2.kddilabs.jp
No package openjdk available.
Error: Nothing to do
ああだめ

4.2jdkやっぱり入ってないよ

>>sudo yum list installed
jdkがインストールされていない。
centosjdkをインストールしたい
>>yum install java-1.8.0-openjdk
[root@z1tg7160-vm01 bin]# yum install java-1.8.0-openjdk
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp-srv2.kddilabs.jp
 * epel: ftp.tsukuba.wide.ad.jp
 * extras: ftp-srv2.kddilabs.jp
 * updates: ftp-srv2.kddilabs.jp
Resolving Dependencies
--> Running transaction check
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.181-3.b13.el7_5 will be installed
--> Processing Dependency: java-1.8.0-openjdk-headless(x86-64) = 1:1.8.0.181-3.b13.el7_5 for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: xorg-x11-fonts-Type1 for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libjvm.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libjava.so(SUNWprivate_1.1)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: fontconfig(x86-64) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libjvm.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libjava.so()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.1.4.1-2.el7 will be installed
---> Package fontconfig.x86_64 0:2.10.95-11.el7 will be installed
--> Processing Dependency: fontpackages-filesystem for package: fontconfig-2.10.95-11.el7.x86_64
--> Processing Dependency: font(:lang=en) for package: fontconfig-2.10.95-11.el7.x86_64
---> Package giflib.x86_64 0:4.1.6-9.el7 will be installed
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.181-3.b13.el7_5 will be installed
--> Processing Dependency: tzdata-java >= 2015d for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: nss-softokn(x86-64) >= 3.36.0 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: nss(x86-64) >= 3.36.0 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: copy-jdk-configs >= 2.2 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: chkconfig >= 1.7 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: chkconfig >= 1.7 for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: lksctp-tools(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
--> Processing Dependency: jpackage-utils for package: 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_64
---> Package libXcomposite.x86_64 0:0.4.4-4.1.el7 will be installed
---> Package libXi.x86_64 0:1.7.9-1.el7 will be installed
---> Package libXrender.x86_64 0:0.9.10-1.el7 will be installed
---> Package libXtst.x86_64 0:1.2.3-1.el7 will be installed
---> Package libpng.x86_64 2:1.5.13-7.el7_2 will be installed
---> Package xorg-x11-fonts-Type1.noarch 0:7.5-9.el7 will be installed
--> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
--> Processing Dependency: ttmkfdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
--> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
--> Processing Dependency: mkfontdir for package: xorg-x11-fonts-Type1-7.5-9.el7.noarch
--> Running transaction check
---> Package chkconfig.x86_64 0:1.3.61-5.el7 will be updated
---> Package chkconfig.x86_64 0:1.7.4-1.el7 will be an update
---> Package copy-jdk-configs.noarch 0:3.3-10.el7_5 will be installed
---> Package fontpackages-filesystem.noarch 0:1.44-8.el7 will be installed
---> Package javapackages-tools.noarch 0:3.4.1-11.el7 will be installed
--> Processing Dependency: python-javapackages = 3.4.1-11.el7 for package: javapackages-tools-3.4.1-11.el7.noarch
--> Processing Dependency: libxslt for package: javapackages-tools-3.4.1-11.el7.noarch
---> Package lksctp-tools.x86_64 0:1.0.17-2.el7 will be installed
---> Package lyx-fonts.noarch 0:2.2.3-1.el7 will be installed
---> Package nss.x86_64 0:3.21.0-9.el7_2 will be updated
--> Processing Dependency: nss = 3.21.0-9.el7_2 for package: nss-sysinit-3.21.0-9.el7_2.x86_64
--> Processing Dependency: nss(x86-64) = 3.21.0-9.el7_2 for package: nss-tools-3.21.0-9.el7_2.x86_64
---> Package nss.x86_64 0:3.36.0-5.el7_5 will be an update
--> Processing Dependency: nss-pem(x86-64) for package: nss-3.36.0-5.el7_5.x86_64
---> Package nss-softokn.x86_64 0:3.16.2.3-14.2.el7_2 will be updated
---> Package nss-softokn.x86_64 0:3.36.0-5.el7_5 will be an update
---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be installed
---> Package tzdata-java.noarch 0:2018e-3.el7 will be installed
---> Package xorg-x11-font-utils.x86_64 1:7.5-20.el7 will be installed
--> Processing Dependency: libfontenc.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
--> Processing Dependency: libXfont.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.5-20.el7.x86_64
--> Running transaction check
---> Package libXfont.x86_64 0:1.5.2-1.el7 will be installed
---> Package libfontenc.x86_64 0:1.1.3-3.el7 will be installed
---> Package libxslt.x86_64 0:1.1.28-5.el7 will be installed
---> Package nss-pem.x86_64 0:1.0.3-4.el7 will be installed
---> Package nss-sysinit.x86_64 0:3.21.0-9.el7_2 will be updated
---> Package nss-sysinit.x86_64 0:3.36.0-5.el7_5 will be an update
---> Package nss-tools.x86_64 0:3.21.0-9.el7_2 will be updated
---> Package nss-tools.x86_64 0:3.36.0-5.el7_5 will be an update
---> Package python-javapackages.noarch 0:3.4.1-11.el7 will be installed
--> Processing Dependency: python-lxml for package: python-javapackages-3.4.1-11.el7.noarch
--> Running transaction check
---> Package python-lxml.x86_64 0:3.2.1-4.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                      Arch    Version                    Repository
                                                                           Size
================================================================================
Installing:
 java-1.8.0-openjdk           x86_64  1:1.8.0.181-3.b13.el7_5    updates  250 k
Installing for dependencies:
 alsa-lib                     x86_64  1.1.4.1-2.el7              base     422 k
 copy-jdk-configs             noarch  3.3-10.el7_5               updates   21 k
 fontconfig                   x86_64  2.10.95-11.el7             base     229 k
 fontpackages-filesystem      noarch  1.44-8.el7                 base     9.9 k
 giflib                       x86_64  4.1.6-9.el7                base      40 k
 java-1.8.0-openjdk-headless  x86_64  1:1.8.0.181-3.b13.el7_5    updates   32 M
 javapackages-tools           noarch  3.4.1-11.el7               base      73 k
 libXcomposite                x86_64  0.4.4-4.1.el7              base      22 k
 libXfont                     x86_64  1.5.2-1.el7                base     152 k
 libXi                        x86_64  1.7.9-1.el7                base      40 k
 libXrender                   x86_64  0.9.10-1.el7               base      26 k
 libXtst                      x86_64  1.2.3-1.el7                base      20 k
 libfontenc                   x86_64  1.1.3-3.el7                base      31 k
 libpng                       x86_64  2:1.5.13-7.el7_2           base     213 k
 libxslt                      x86_64  1.1.28-5.el7               base     242 k
 lksctp-tools                 x86_64  1.0.17-2.el7               base      88 k
 lyx-fonts                    noarch  2.2.3-1.el7                epel     159 k
 nss-pem                      x86_64  1.0.3-4.el7                base      73 k
 python-javapackages          noarch  3.4.1-11.el7               base      31 k
 python-lxml                  x86_64  3.2.1-4.el7                base     758 k
 ttmkfdir                     x86_64  3.0.9-42.el7               base      48 k
 tzdata-java                  noarch  2018e-3.el7                updates  185 k
 xorg-x11-font-utils          x86_64  1:7.5-20.el7               base      87 k
 xorg-x11-fonts-Type1         noarch  7.5-9.el7                  base     521 k
Updating for dependencies:
 chkconfig                    x86_64  1.7.4-1.el7                base     181 k
 nss                          x86_64  3.36.0-5.el7_5             updates  835 k
 nss-softokn                  x86_64  3.36.0-5.el7_5             updates  315 k
 nss-sysinit                  x86_64  3.36.0-5.el7_5             updates   62 k
 nss-tools                    x86_64  3.36.0-5.el7_5             updates  514 k

Transaction Summary
================================================================================
Install  1 Package  (+24 Dependent packages)
Upgrade             (  5 Dependent packages)

Total download size: 37 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/30): copy-jdk-configs-3.3-10.el7_5.noarch.rpm           |  21 kB   00:00     
(2/30): alsa-lib-1.1.4.1-2.el7.x86_64.rpm                  | 422 kB   00:00     
(3/30): giflib-4.1.6-9.el7.x86_64.rpm                      |  40 kB   00:00     
(4/30): java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64.rp | 250 kB   00:00     
(5/30): fontpackages-filesystem-1.44-8.el7.noarch.rpm      | 9.9 kB   00:00     
(6/30): javapackages-tools-3.4.1-11.el7.noarch.rpm         |  73 kB   00:00     
(7/30): libXfont-1.5.2-1.el7.x86_64.rpm                    | 152 kB   00:00     
(8/30): fontconfig-2.10.95-11.el7.x86_64.rpm               | 229 kB   00:00     
(9/30): libXi-1.7.9-1.el7.x86_64.rpm                       |  40 kB   00:00     
(10/30): libXtst-1.2.3-1.el7.x86_64.rpm                    |  20 kB   00:00     
(11/30): chkconfig-1.7.4-1.el7.x86_64.rpm                  | 181 kB   00:00     
(12/30): libXcomposite-0.4.4-4.1.el7.x86_64.rpm            |  22 kB   00:00     
(13/30): libXrender-0.9.10-1.el7.x86_64.rpm                |  26 kB   00:00     
(14/30): libpng-1.5.13-7.el7_2.x86_64.rpm                  | 213 kB   00:00     
(15/30): libxslt-1.1.28-5.el7.x86_64.rpm                   | 242 kB   00:00     
(16/30): lksctp-tools-1.0.17-2.el7.x86_64.rpm              |  88 kB   00:00     
(17/30): nss-3.36.0-5.el7_5.x86_64.rpm                     | 835 kB   00:00     
(18/30): lyx-fonts-2.2.3-1.el7.noarch.rpm                  | 159 kB   00:00     
(19/30): nss-softokn-3.36.0-5.el7_5.x86_64.rpm             | 315 kB   00:00     
(20/30): nss-pem-1.0.3-4.el7.x86_64.rpm                    |  73 kB   00:00     
(21/30): nss-tools-3.36.0-5.el7_5.x86_64.rpm               | 514 kB   00:00     
(22/30): libfontenc-1.1.3-3.el7.x86_64.rpm                 |  31 kB   00:00     
(23/30): python-javapackages-3.4.1-11.el7.noarch.rpm       |  31 kB   00:00     
(24/30): nss-sysinit-3.36.0-5.el7_5.x86_64.rpm             |  62 kB   00:00     
(25/30): ttmkfdir-3.0.9-42.el7.x86_64.rpm                  |  48 kB   00:00     
(26/30): tzdata-java-2018e-3.el7.noarch.rpm                | 185 kB   00:00     
(27/30): xorg-x11-fonts-Type1-7.5-9.el7.noarch.rpm         | 521 kB   00:00     
(28/30): xorg-x11-font-utils-7.5-20.el7.x86_64.rpm         |  87 kB   00:00     
(29/30): python-lxml-3.2.1-4.el7.x86_64.rpm                | 758 kB   00:00     
(30/30): java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5 |  32 MB   00:01     
--------------------------------------------------------------------------------
Total                                               20 MB/s |  37 MB  00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : nss-softokn-3.36.0-5.el7_5.x86_64                           1/35 
  Installing : libfontenc-1.1.3-3.el7.x86_64                               2/35 
  Updating   : chkconfig-1.7.4-1.el7.x86_64                                3/35 
  Updating   : nss-sysinit-3.36.0-5.el7_5.x86_64                           4/35 
  Updating   : nss-3.36.0-5.el7_5.x86_64                                   5/35 
  Installing : nss-pem-1.0.3-4.el7.x86_64                                  6/35 
  Installing : libxslt-1.1.28-5.el7.x86_64                                 7/35 
  Installing : fontpackages-filesystem-1.44-8.el7.noarch                   8/35 
  Installing : libXi-1.7.9-1.el7.x86_64                                    9/35 
  Installing : libXtst-1.2.3-1.el7.x86_64                                 10/35 
  Installing : lyx-fonts-2.2.3-1.el7.noarch                               11/35 
  Installing : fontconfig-2.10.95-11.el7.x86_64                           12/35 
  Installing : python-lxml-3.2.1-4.el7.x86_64                             13/35 
  Installing : python-javapackages-3.4.1-11.el7.noarch                    14/35 
  Installing : javapackages-tools-3.4.1-11.el7.noarch                     15/35 
  Installing : libXfont-1.5.2-1.el7.x86_64                                16/35 
  Installing : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                    17/35 
  Installing : alsa-lib-1.1.4.1-2.el7.x86_64                              18/35 
  Installing : tzdata-java-2018e-3.el7.noarch                             19/35 
  Installing : lksctp-tools-1.0.17-2.el7.x86_64                           20/35 
  Installing : libXcomposite-0.4.4-4.1.el7.x86_64                         21/35 
  Installing : copy-jdk-configs-3.3-10.el7_5.noarch                       22/35 
  Installing : 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_   23/35 
  Installing : ttmkfdir-3.0.9-42.el7.x86_64                               24/35 
  Installing : xorg-x11-fonts-Type1-7.5-9.el7.noarch                      25/35 
  Installing : 2:libpng-1.5.13-7.el7_2.x86_64                             26/35 
  Installing : libXrender-0.9.10-1.el7.x86_64                             27/35 
  Installing : giflib-4.1.6-9.el7.x86_64                                  28/35 
  Installing : 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64          29/35 
  Updating   : nss-tools-3.36.0-5.el7_5.x86_64                            30/35 
  Cleanup    : nss-tools-3.21.0-9.el7_2.x86_64                            31/35 
  Cleanup    : nss-sysinit-3.21.0-9.el7_2.x86_64                          32/35 
  Cleanup    : nss-3.21.0-9.el7_2.x86_64                                  33/35 
  Cleanup    : chkconfig-1.3.61-5.el7.x86_64                              34/35 
  Cleanup    : nss-softokn-3.16.2.3-14.2.el7_2.x86_64                     35/35 
  Verifying  : libXi-1.7.9-1.el7.x86_64                                    1/35 
  Verifying  : giflib-4.1.6-9.el7.x86_64                                   2/35 
  Verifying  : nss-pem-1.0.3-4.el7.x86_64                                  3/35 
  Verifying  : libXrender-0.9.10-1.el7.x86_64                              4/35 
  Verifying  : lyx-fonts-2.2.3-1.el7.noarch                                5/35 
  Verifying  : libXfont-1.5.2-1.el7.x86_64                                 6/35 
  Verifying  : python-lxml-3.2.1-4.el7.x86_64                              7/35 
  Verifying  : 2:libpng-1.5.13-7.el7_2.x86_64                              8/35 
  Verifying  : fontpackages-filesystem-1.44-8.el7.noarch                   9/35 
  Verifying  : ttmkfdir-3.0.9-42.el7.x86_64                               10/35 
  Verifying  : copy-jdk-configs-3.3-10.el7_5.noarch                       11/35 
  Verifying  : python-javapackages-3.4.1-11.el7.noarch                    12/35 
  Verifying  : libXcomposite-0.4.4-4.1.el7.x86_64                         13/35 
  Verifying  : libXtst-1.2.3-1.el7.x86_64                                 14/35 
  Verifying  : lksctp-tools-1.0.17-2.el7.x86_64                           15/35 
  Verifying  : 1:java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64          16/35 
  Verifying  : 1:java-1.8.0-openjdk-headless-1.8.0.181-3.b13.el7_5.x86_   17/35 
  Verifying  : xorg-x11-fonts-Type1-7.5-9.el7.noarch                      18/35 
  Verifying  : nss-tools-3.36.0-5.el7_5.x86_64                            19/35 
  Verifying  : libxslt-1.1.28-5.el7.x86_64                                20/35 
  Verifying  : javapackages-tools-3.4.1-11.el7.noarch                     21/35 
  Verifying  : 1:xorg-x11-font-utils-7.5-20.el7.x86_64                    22/35 
  Verifying  : fontconfig-2.10.95-11.el7.x86_64                           23/35 
  Verifying  : tzdata-java-2018e-3.el7.noarch                             24/35 
  Verifying  : nss-3.36.0-5.el7_5.x86_64                                  25/35 
  Verifying  : chkconfig-1.7.4-1.el7.x86_64                               26/35 
  Verifying  : libfontenc-1.1.3-3.el7.x86_64                              27/35 
  Verifying  : nss-softokn-3.36.0-5.el7_5.x86_64                          28/35 
  Verifying  : nss-sysinit-3.36.0-5.el7_5.x86_64                          29/35 
  Verifying  : alsa-lib-1.1.4.1-2.el7.x86_64                              30/35 
  Verifying  : nss-softokn-3.16.2.3-14.2.el7_2.x86_64                     31/35 
  Verifying  : nss-3.21.0-9.el7_2.x86_64                                  32/35 
  Verifying  : nss-tools-3.21.0-9.el7_2.x86_64                            33/35 
  Verifying  : nss-sysinit-3.21.0-9.el7_2.x86_64                          34/35 
  Verifying  : chkconfig-1.3.61-5.el7.x86_64                              35/35 

Installed:
  java-1.8.0-openjdk.x86_64 1:1.8.0.181-3.b13.el7_5                             

Dependency Installed:
  alsa-lib.x86_64 0:1.1.4.1-2.el7                                               
  copy-jdk-configs.noarch 0:3.3-10.el7_5                                        
  fontconfig.x86_64 0:2.10.95-11.el7                                            
  fontpackages-filesystem.noarch 0:1.44-8.el7                                   
  giflib.x86_64 0:4.1.6-9.el7                                                   
  java-1.8.0-openjdk-headless.x86_64 1:1.8.0.181-3.b13.el7_5                    
  javapackages-tools.noarch 0:3.4.1-11.el7                                      
  libXcomposite.x86_64 0:0.4.4-4.1.el7                                          
  libXfont.x86_64 0:1.5.2-1.el7                                                 
  libXi.x86_64 0:1.7.9-1.el7                                                    
  libXrender.x86_64 0:0.9.10-1.el7                                              
  libXtst.x86_64 0:1.2.3-1.el7                                                  
  libfontenc.x86_64 0:1.1.3-3.el7                                               
  libpng.x86_64 2:1.5.13-7.el7_2                                                
  libxslt.x86_64 0:1.1.28-5.el7                                                 
  lksctp-tools.x86_64 0:1.0.17-2.el7                                            
  lyx-fonts.noarch 0:2.2.3-1.el7                                                
  nss-pem.x86_64 0:1.0.3-4.el7                                                  
  python-javapackages.noarch 0:3.4.1-11.el7                                     
  python-lxml.x86_64 0:3.2.1-4.el7                                              
  ttmkfdir.x86_64 0:3.0.9-42.el7                                                
  tzdata-java.noarch 0:2018e-3.el7                                              
  xorg-x11-font-utils.x86_64 1:7.5-20.el7                                       
  xorg-x11-fonts-Type1.noarch 0:7.5-9.el7                                       

Dependency Updated:
  chkconfig.x86_64 0:1.7.4-1.el7         nss.x86_64 0:3.36.0-5.el7_5           
  nss-softokn.x86_64 0:3.36.0-5.el7_5    nss-sysinit.x86_64 0:3.36.0-5.el7_5   
  nss-tools.x86_64 0:3.36.0-5.el7_5     

Complete!
>>java --version
[root@z1tg7160-vm01 bin]# java -version
openjdk version "1.8.0_181"
OpenJDK Runtime Environment (build 1.8.0_181-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

javaが入った。
結果:だめ

6.pycharmクライアントからsshのサーバ設定する

SSH Interpreterが存在しない

6.2 pycharm interpreterを検索

ここまでで完全思考停止